Cesium desktop bloqué en mode "Veuillez patienter..."


#1

Salut,

Je galère avec l’utilisation de Cesium sur desktop.

Que ce soit avec l’application pour Ubuntu ou avec la version accessible via navigateur, lorsque j’essaye de me connecter, je reste bloqué sur “Veuillez patienter…” :

Si je ferme et que je rouvre, j’obtiens :

Pourtant, ça semble bien se passer avec l’application Android.

Une idée de ce qui pourrait causer ce problème que je rencontre ?

Merci d’avance,

Boris


#2

Bonjour,

As-tu reçu un versement sur ce compte ? Un “compte inactif” n’a reçu aucune June. Si non, tu peux transférer au moins 1 G1 sur ce compte pour l’activer. Si tu n’en as pas, donne moi l’adresse, je le ferai.

Concernant l’attente, ça m’arrive régulièrement, plutôt sur mobile. Je crois que c’est lié à la disponibilité du noeud.

Sur l’app android, tu restes connecté, donc il ne te redemande pas à chaque fois si c’est bien ce compte que tu souhaites ouvrir. En tout cas c’est ce que je suppose :-p


#3

Pas forcément, pour etre plus précis : un compte inactif est un compte sur lequel il n’y a eu aucune activité récente (je ne sais pas quel est le délai exact choisi par Cesium).

Mais j’ai déjà eu des cas de portefeuille que Cesium me déclarais inactif alors que j’avais déposé des G1 dessus plusieurs mois avant.


#4

Aaaaaah, okayyyy…

Merci pour vos explications.

Effectivement, je n’ai pas encore de Junes sur ce compte.

Merci, c’est très gentil :slight_smile: Ceci dit, quel est l’intérêt ? C’est grave si mon compte reste inactif jusqu’à ma première vente ? Quel est l’intérêt d’avoir un compte actif ? Pouvoir ajouter la clef publique à ğchange, peut-être ?

Merci encore pour vos réponses :slight_smile:


#5

Effectivement, ça n’a pas grand intérêt.

Faire un aller-retour avec 1G1 permet d’indiquer que tu maitrises bien ce compte, ce qui peut éviter des tracasseries en transactions. Mais c’est tout.

(J’ai envoyé de la monnaie sur un compte vide dont on avait perdu les identifiants. La prochaine fois, je demande cet envoi de verification)


#6

Il y a peut être aussi un bug (je penses au Veuillez Patientez qui reste affiché), car nous avons eu des régressions récemment suite a des noeuds Duniter déployés trop tôt en v1.7

Peux tu me dire :

  • sur quel noeud Duniter tu étais (dans les paramètres Césium)
  • ta version de Césium
  • ta clef publique de compte (pour je puisse reproduire)

A+


#7

g1.duniter.org

v.1.2.9

JE6mkuzSpT3ePciCPRTpuMT9fqPUVVLJz2618d33p7tn


#8

Tiens c’est marrant j’ai l’impression que j’ai plus de bug maintenant.

Tu as touché quelque chose @kimamila ?


#9

J’ai aussi le même problème.

  • Je me connecte à mon propre nœud (127.0.0.1:57586)
  • Cesium 1.2.9
  • Pubkey : CRBxCJrTA6tmHsgt9cQh9SHcCc8w8q95YTp38CPHx2Uk

En général je contourne le problème en le laissant mouliner une minute. Puis je le ferme et le réouvre aussitôt. En général, ça marche.


#10

@gerard94 Peux tu essayer avec la même version de Cesium, mais en web (zip à désarchiver) puis en ouvrant le fichier debug.html. Et enfin en ouvrant la console javascript (Ctrl+Maj+i sous Chrome ou Firefox). Et me copier le contenu du log.

Merci !


#11

Cette fois, le démarrage s’est bien passé, mais je n’ai pas pu me connecter à “Mes opérations”. Le log :

Successfully compiled asm.js code (total compilation time 312ms; unable to cache asm.js in synchronous scripts; try loading asm.js via <script async> or createElement('script')) vendor.js
Successfully compiled asm.js code (total compilation time 42ms; unable to cache asm.js in synchronous scripts; try loading asm.js via <script async> or createElement('script')) vendor.js
Adding String.prototype.format() -> was missing on this platform cesium.js:48904:3
[storage] Starting {local} storage... cesium.js:4437:9
[settings] Fix locale [fr] -> [fr-FR] cesium.js:44:7
[settings] Locale [fr-FR] cesium.js:253:5
[app] Root path is [file:///home/gerard/Bidon/Cesium/debug.html] cesium.js:48811:5
[settings] Starting... cesium.js:284:5
[storage] Started in 50ms cesium.js:4513:11
[settings] No settings in local storage. Using defaults. cesium.js:230:13
[settings] Started cesium.js:293:9
[crypto] Starting... cesium.js:1915:7
[crypto] Loading FullJS implementation... cesium.js:1926:9
[device] Ionic platform ready - no device detected. cesium.js:4778:15
[crypto] Loaded 'FullJS' implementation in 31ms cesium.js:1938:11
[BMA] Starting [g1.duniter.org] (SSL on)... cesium.js:5423:9
[app] Current version [1.2.9] is the latest release cesium.js:48866:13
[http] TODO: implement check version [1.6.29] compatible with [1.1.0] cesium.js:4270:5
[BMA] Started in 1725ms cesium.js:5448:11
[currency] Starting... cesium.js:5000:7
[http] Waiting websocket [/ws/block] opening... cesium.js:3996:9
[currency] Started in 264ms cesium.js:5012:11
[wallet] Starting... cesium.js:9986:7
[wallet] Started in 0ms cesium.js:10005:11
[filter] Loading translations for locale [fr-FR] cesium.js:48066:7
[ES] [http] Starting on [g1.data.duniter.fr] (SSL on)... cesium.js:30035:11
[filter] Computing constants from currency parameters cesium.js:48094:7
[http] Listening on websocket [/ws/block]... cesium.js:4024:13
[currency] Received new block [186116-000001D2206283ADCA469937C7DB7F7F4F98CFE3B2A3518E8AE58D81C43BA4E1] cesium.js:4950:7
[ES] [http] Started in 181ms cesium.js:30055:15
[ES] [profile] Enable cesium.js:31875:9
[ES] [notification] Enable cesium.js:32317:7
[ES] [wallet] Enable cesium.js:34354:9
[ES] [message] Enable cesium.js:32993:9
[ES] [subscription] Enable cesium.js:31113:7
[ES] [group] Enable cesium.js:33506:7
[ES] [invitations] Enable cesium.js:33915:7
[ES] [subscription] Enable cesium.js:34160:7
[ES] [tx] Enable cesium.js:34604:9
[ES] [settings] Enable cesium.js:30798:11
[login] method is: SCRYPT_DEFAULT cesium.js:12084:5
[login] method is: PUBKEY cesium.js:12084:5
[ES] [notification] Loading count...CRBxCJrT cesium.js:32228:5
[ES] [wallet] Loading user avatar+name... cesium.js:34249:7
[ES] [message] Loading count... cesium.js:32419:7
[ES] [invitation] Loading count... cesium.js:33609:5
[setting] Saved locally cesium.js:174:11
[ES] [notification] Loaded count (437) in 240ms cesium.js:32252:9
[ES] [message] Loaded count (0) in 314ms cesium.js:32427:11
[ES] [invitation] Loaded count (0) in 314ms cesium.js:33617:9
[ES] [group] Detecting 0 unread notifications cesium.js:33318:9
[ES] [wallet] Loaded user avatar+name in 322ms cesium.js:34258:13
[ES] [notification] Starting listen user event... cesium.js:32266:9
[http] Waiting websocket [/ws/event/user/:pubkey/:locale] opening... cesium.js:3996:9
[wallet] Storing... cesium.js:8121:11
[wallet] Stored in 21ms cesium.js:8146:15
[http] Listening on websocket [/ws/event/user/:pubkey/:locale]... cesium.js:4024:13
[tx] TX and sources loaded in 14166ms cesium.js:7644:17
[wot] Requirements for 'CRBxCJrT' loaded in 22285ms cesium.js:6336:13
Error while requesting [https://g1.duniter.org/wot/certified-by/CRBxCJrTA6tmHsgt9cQh9SHcCc8w8q95YTp38CPHx2Uk]
cesium.js:48579:12
Erreur dans les liens source : TypeError: NetworkError when attempting to fetch resource.
URL de la ressource : file:///home/gerard/Bidon/Cesium/dist_js/vendor.js
URL du lien source : angular-chart.min.js.map[En savoir plus]
[currency] Received new block [186117-000002B66B056331F8C91EA47E9F689357ED66B0D5D977493103E60FF26F02FC] cesium.js:4950:7

​

#12

L’erreur que tu rencontre est liée à celle-ci :

@cgeek, une idée ? Peut-etre est-ce la sécurité des quotas sur les requetes… car évident, impossible à reproduire…


#13

tu reproduis à chaque fois, @gerard94 ?


#14

Ça ne se produit pas si je demande “Mes opérations” en premier. Mais si je fais autre chose avant, ça plante.


#15

Si ça peut être utile pour le débug : j’ai eu le même problème hier juste après avoir créé mon premier compte (nœud = g1.duniter.org, version = 1.2.9). Ça s’est arrangé tout seul après 30 min. Là je viens de relancer Césium desktop et je n’ai pas de problème.


#16

Voici le ticket, pour suivre cela : https://git.duniter.org/clients/cesium-grp/cesium/issues/793 Je vais regarder ce que je peux faire.


#17

@gerard94 @BorisPaing est-ce que ca marche mieux en v1.3.5 chez vous ??


#18

Salut,

J’ai plus eu de problèmes ces derniers temps, et je n’avais pas encore fait la MàJ.

Je viens donc de faire la MàJ vers 1.3.6

Et toujours pas de problème.

J’ai regardé ma capture d’écran, et la clé publique affichée ne correspond à aucun de mes comptes. Donc c’est très probablement moi qui avait merdé. J’étais peut-être en CAPS LOCK ou une connerie comme ça. Désolé :sweat_smile:


#19

Peut-etre aussi un problème lié au Noeud Duniter. A suivre !


#20

La version 1.3.6 semble bien fonctionner. Mais, depuis la dernière fois, j’ai changé la version de mon nœud de 1.6.30 à 1.7.12. C’est peut-être juste dû à ça.