Bug sur cesium et gchange app / Android 10

Impossible de démarrer cesium et gchange sur android 10 1.miui.home

Euh, c’est pas ici qu’il faut l’envoyer mais sur https://git.duniter.org/clients/cesium-grp/cesium/issues/new et https://git.duniter.org/marketplaces/gchange-client/issues/new

dsl pensé être au service technique je fais suivre

Non, on a pas encore de hotline digne de ce nom.

:smiley: bon mais je n’arrive pas à faire suivre espérant qu’il y a un développeur sur android 10

@kimamila https://git.duniter.org/clients/cesium-grp/cesium/issues/898

1 J'aime

Tu peux pas essayer une version précédente en attendant ?

j’ai testé la 1.6.0 même problème je vais essayer plus ancienne

suis remonté jusqu’à la 1.5.5 idem

Fait de la bissection entre les versions 1.3.11 et 1.5.5.

je les ai toutes essayé c’est pas bon

Dans ce cas, ça signifie que les versions ≥ 1.3.11 n’ont jamais fonctionné sur Android 10 et ou sur ton mobile.

certainement Android 10 n’est pas sorti depuis longtemps

oui mais ça fonctionné il y moins d’une semaine

Merci pour ce retour. Petite question : as tu défini un verrouillage de ton téléphone ? Y a t’il bien un code ou un schéma sur l’écran d’accueil ? Si non, peux tu essayer d’en ajouter un (via les paramètres Android), puis me redire si ca marche mieux.

Logiquement Cesium devrait s’adapter aux 2 cas, mais bon… ca sent le bug :slight_smile:

oui par empreinte et par shema mais cela ne change rien j’ai 2 contacts avec le même tel c’est la même chose

surtout que ça a fonctionné et gchange même problème maintenant

Salut Ben, je viens de tester cesium sur Android et même problème. L’appli se ferme tout de suite mais pas le temps de voir quoi que ce soit. Entre temps le seul changement effectué sur mon téléphone est une mise à jour d’android.

La version 1.4.1 fonctionne sur android 10

1 J'aime

super, ca me donne une bonne base pour chercher l’erreur. Cesium utilise Cordova (le code de l’erreur vient de là). Je vais regader. @bpresles si tu peux m’aider aussi de ton côté ? Ca risque de venir urgent, pas mal d’utilisateur sont bloqués, mais demain je ne pourrais pas m’y consacrer (trop de travail en ce moment, dans mon boulot-euro…)

EDIT: ok j’ai trouvé le problème. Il s’agit du plugin qui permet de sauvegarder les données dans les données chiffrés. Faut voir comment on peut passer une version corrigé du plugin.