Blocage Cesium après plantage

Bonjour, Après un changement de version de Cesium vers la version 1.3.11, sur mon PC portable, je suis complètement bloqué. Comment je fais pour détruire toutes les données qu’a laissé la dernière utilisation de la version 1.9 qui s’était plantée (suite à un arrêt brutal de mon ordinateur).

Hello,

Ça dépend de beaucoup de facteurs : quel est ton OS ? As-tu installé la version web, ou es-tu passé par l’install manager ? As-tu accès aux logs de plantage ?

Si tu as la version web locale, il suffit d’effacer le dossier cesium-desktop et de foutre la nouvelle à la place.

Si c’est la version package, il faut passer par l’installeur et tout virer avant de réinstaller le nouveau. pour linux ce sera un petit apt purge cesium-desktop (pour debian), pour windows une désinstallation totale, pour mac j’en sais rien.

Au pire, tu peux toujours utiliser la version web locale et partir de index.html dans ton dossier cesium. Ça, ça marche à tous les coups (c’est plus safe que le web pur mais moins que l’install “en dur”).

Merci pour le conseil d’utilisation de la commande apt purge cesium-desktop puisque je suis sous Debian. Cependant, je ne m’en sors pas en version 1.3.11. cesium affiche dans un terminal de lancement les erreurs suivantes :

Fontconfig warning: “/etc/fonts/fonts.conf”, line 100: unknown element “blank”

[9760:9760:0713/141854.164837:ERROR:component_loader.cc(164)] Failed to parse extension manifest.

ATTENTION: default value of option force_s3tc_enable overridden by environment. [9786:9786:0713/141854.794159:ERROR:sandbox_linux.cc(366)] InitializeSandbox() called with multiple threads in process gpu-process.

[9797:9818:0713/141855.355790:ERROR:command_buffer_proxy_impl.cc(105)] ContextResult::kTransientFailure: Shared memory region is not valid

La version 1.2.9 fonctionnait correctement.

Si j’essaie de revenir en version 1.2.9 (non stable), je me heurte à une incompatibilité de format de base de données dont j’ignore où elle se trouve et comment la détruire :

[10032:10046:0713/143332.443916:ERROR:web_database_backend.cc(113)] Cannot initialize the web database: 2

[10032:10060:0713/143332.473780:ERROR:connection.cc(1954)] sqlite error 1, errno -2: table urls has 8 columns but 7 values were supplied, sql: INSERT INTO urls SELECT * FROM history.urls WHERE typed_count > 0

[10032:10060:0713/143332.474533:ERROR:connection.cc(1954)] sqlite error 1, errno -2: no such column: u.favicon_id, sql: INSERT OR IGNORE INTO urls SELECT u.id, u.url, u.title, u.visit_count, u.typed_count, u.last_visit_time, u.hidden, u.favicon_id FROM history.urls u JOIN history.keyword_search_terms kst WHERE u.typed_count = 0 AND u.id = kst.url_id

Erreur de segmentation

woaw, bizarre… On dirait qu’un reste de je ne sais quoi traine et pollue ta nouvelle install.

Fonts c’est les typo, peut être qu’il te manque celle de cesium ?

T’as essayé la dernière version instable 1.4.2 ?

@kimamila, help ! Ça te dit quelque chose ce beanz ?

Peux tu tester :

# Suppression de l'ancienne installation
sudo apt-get remove cesium-desktop

# Supression des données locales (paramètres, etc)
rm -rf ~/.config/cesium

# Réinstallation propre
sudo dpkg -i cesium-desktop-vX.Y.Z.deb

# Lancement
cesium